Activity Feed Forums Printing Discussions Roland Printers Help! weird print problem – solid black all over print SP300

  • Help! weird print problem – solid black all over print SP300

    Posted by Michael Fear on November 4, 2019 at 8:45 am

    Printer was working fine, went to use it the next day and rather than print out say the text, it is just printing solid black over everything ( so if I was printing a line of text for example, all I would get would be a big black rectangle )

    Anyone had anything similar or can help? it is like the printer is telling the print head to just output ink all the time rather than the selected bits needed to make up the text ?

    Michael Fear Michael Fear replied 2 years, 6 months ago 3 Members · 4 Replies
  • 4 Replies
  • Chris Wool

    Member
    November 4, 2019 at 10:18 am

    welcome see your first post needing help

    the fault is normally associated with the head flat cables what about other colours. oh and switch it off before rummaging around with cables.

  • Michael Fear Michael Fear

    Member
    November 4, 2019 at 10:50 am

    Hi, thanks for the reply! I will give the cables a plug and unplug and see if that makes any difference.

    Magenta and yellow are fine, it seems to be the blue / black side causing the problem

  • John Thomson

    Member
    November 4, 2019 at 12:28 pm

    As Chris has said the most likely cause is a badly seated head ribbon, next place to look is headboard when things start to get expensive very quickly.

    John

  • Michael Fear Michael Fear

    Member
    November 5, 2019 at 8:40 am

    Thanks all, looks like it was the ribbon. I checked it and it looked full pressed in, but removed it, gave it a clean and reinstalled and it is back to normal again