Find answers, ask questions, connect with our community.

Activity Feed Forums Sign Discussion General Sign Topics East Mount 1600 lamination problems, please help!?

  • East Mount 1600 lamination problems, please help!?

  • Dean Poulter

    Member
    February 20, 2020 at 8:33 am

    I have had my easy mount for 10 years and never had any problems but all of a sudden everything I put through after about 2m it starts creasing the only thing I have changed is the laminate metamark has any one else had any problems

    Cheers Dean

  • Dean Poulter

    Member
    February 20, 2020 at 10:10 am

    update tried 1 meter through my old hand laminator and had exactly the same outcome

    i am now starting to think its a problem with the laminate

    next stop try a different laminate

  • John Thomson

    Member
    February 20, 2020 at 10:32 am

    Too much pressure for the different material?

    John

  • Robert Lambie

    Member
    February 20, 2020 at 11:09 am

    Could the laminate or base vinyl be cold and cockling the media as it goes through the rollers.

  • Dean Poulter

    Member
    February 20, 2020 at 11:13 am

    i have just used a bit of hexis laminate and i went through perfect

  • Graeme Dingwall

    Member
    February 20, 2020 at 1:49 pm
    quote Dean Poulter:

    i have just used a bit of hexis laminate and i went through perfect

    I did have an issue with metamark a while back it was the laminate something to do with the backing paper I think. Not used much lately so dont know of it’s the same thing. Bloody annoying tho

  • Dean Poulter

    Member
    February 20, 2020 at 1:53 pm

    to be fair the laminator nearly went out the window !!

  • Graeme Dingwall

    Member
    February 20, 2020 at 2:07 pm

    Yeah start laminating then it all wants to bunch into the middle f***ing nightmare. Contact your supplier you might get a free roll out of it.

Log in to reply.

Original Post
0 of 0 posts June 2018
Now